Elevated API Errors on Feature Flags and App

Incident Report for PostHog

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 23:40 UTC

Monitoring

A fix has been deployed, and requests to the /flags endpoint should have lower latency once again. We're still monitoring.
Posted Oct 28, 2025 - 21:34 UTC

Update

Our app is now accessible again. Feature flags are slowly recovering, but you might still see timeouts and/or increased latency. We're working on a fix.
Posted Oct 28, 2025 - 21:28 UTC

Update

Apologies for the continued troubles. We have multiple engineers investigating and working to resolve this incident ASAP.
Posted Oct 28, 2025 - 21:06 UTC

Update

We are investigating errors in our feature flag service. Our app is currently inaccessible.
Posted Oct 28, 2025 - 19:58 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Oct 28, 2025 - 19:37 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Oct 28, 2025 - 19:33 UTC
This incident affected: US Cloud 🇺🇸 (App, Feature Flags and Experiments).