US Realtime Destination Data Processing Delays

Incident Report for PostHog

Resolved

US Realtime Destination lag is recovering. No data was lost and events should now be delivered within normal latency
Posted Aug 20, 2025 - 16:03 UTC

Investigating

Our realtime event destination infrastructure is running behind which is causing delays in event deliveries. No data has been lost and we are working to resolve the delay.
Posted Aug 20, 2025 - 15:38 UTC
This incident affected: US Cloud 🇺🇸 (Destinations).