Processing Delays

Incident Report for PostHog

Resolved

We've resolved the issue and ingestion has caught up to real time
Posted Apr 12, 2025 - 17:06 UTC

Update

We're keeping a close eye on our ingestion delay. Events might take up to 35 minutes to show up inside PostHog in our EU Cloud. No data has been lost.
Posted Apr 12, 2025 - 15:15 UTC

Investigating

Our EU data processing infrastructure is running behind, which is causing inaccuracies in the reporting tools. No data has been lost, and the system should catch up shortly. We're monitoring it closely.
Posted Apr 12, 2025 - 13:18 UTC
This incident affected: EU Cloud 🇪🇺 (Event and Data Ingestion).