Data Processing Delays - Reporting Tools Affected

Incident Report for PostHog

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 12, 2025 - 02:12 UTC

Monitoring

The root cause has been identified and slow down to event consumption is mitigated. Operators are monitoring the system as it chews through accumulated events and gets us back to sub-minute ingestion lag.
Posted Aug 12, 2025 - 01:16 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Aug 12, 2025 - 00:12 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion Lag).