Data Processing Delays - Reporting Tools Affected

Incident Report for PostHog

Resolved

Event processing lag is back to normal levels. Incident is resolved.
Posted Jul 11, 2025 - 00:35 UTC

Monitoring

Event processing is healthy again. Lag is coming down, but there is still a healthy back log to get through.
Posted Jul 10, 2025 - 22:38 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up once we root cause the problem and find a resolution.
Posted Jul 10, 2025 - 20:21 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion Lag).