US ingestion lag

Incident Report for PostHog

Resolved

After monitoring we have seen that all systems are working as normally.
Posted Mar 30, 2025 - 16:50 UTC

Monitoring

We have been able to identify the root cause and pushed a fix to get event ingestion back to normal and latency is now back to normal.

We'll keep monitoring the infrastructure.
Posted Mar 30, 2025 - 14:22 UTC

Investigating

Our ingestion infrastructure is processing slowly causing delays for event ingestion. We are investigating what could be the root cause.
Posted Mar 30, 2025 - 13:20 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion).