Delayed Cohort Processing

Incident Report for PostHog

Resolved

Cohorts are being processed normally again. All cohorts that have not been calculated since July 11, 2025 will be calculated within 24hr. If you need a cohort to be calculated sooner, navigate to the cohort in the PostHog app and press the Save button.
Posted Jul 14, 2025 - 19:08 UTC

Identified

We have identified an issue and rolled out a mitigation. Our systems are working though a backlog of cohorts that have not been calculated since 07-11.
Posted Jul 14, 2025 - 17:45 UTC

Investigating

We've spotted a delay in cohort processing. We're currently investigating the issue, and will provide an update soon.
Posted Jul 14, 2025 - 14:04 UTC
This incident affected: US Cloud 🇺🇸 (App) and EU Cloud 🇪🇺 (App).