Elevated errors on us.posthog.com

Incident Report for PostHog

Resolved

The errors have been resolved
Posted Jun 04, 2025 - 18:46 UTC

Investigating

We're seeing elevated errors loading the posthog interface. We're investigating and we'll update you as we know more.
Posted Jun 04, 2025 - 16:02 UTC
This incident affected: US Cloud 🇺🇸 (App).