Data Processing Delays

Incident Report for PostHog

Resolved

The impact from the issue is over. Delayed deliveries for realtime destinations have caught back up.
Posted Jul 29, 2025 - 22:34 UTC

Update

Our team is looking into increased lag in realtime destination delivery. No data has been lost and the system should be caught up shortly.
Posted Jul 29, 2025 - 20:42 UTC

Update

Under provisioning of resources caused delays in realtime delivery. Scaling up our systems resolved the issue and should now run stable.
Posted Jul 29, 2025 - 18:26 UTC

Monitoring

Our data processing infrastructure is running behind which is causing latency in delivery of realtime destinations.
Posted Jul 29, 2025 - 18:16 UTC
This incident affected: US Cloud 🇺🇸 (Destinations).