Elevated query latency and errors

Incident Report for PostHog

Resolved

Duplicate incident, follow "Elevated query API timeouts" for updates
Posted Dec 12, 2025 - 19:47 UTC

Investigating

We're experiencing an elevated level of analytics query latency and errors and are currently looking into the issue.
Posted Dec 12, 2025 - 19:46 UTC
This incident affected: US Cloud 🇺🇸 (App, API /query Endpoint).