Issues setting and unsetting person properties

Incident Report for PostHog

Update

We’re continuing to work on backfilling previously affected data.
As mentioned below, this issue only affected person property updates sent on existing persons between January 6, 20:01 UTC and January 7, 14:52 UTC.

Unfortunately, we are unlikely to be able to backfill person property updates for events that occurred during this time window.
What this means:

- If you create insights that include data from the incident time frame and are filtered by person properties, PostHog will use the pre-incident person property value for persons that existed before the incident.
- If you need the correct property, you can select "Use person properties from query time" under "advanced options" to create an insight.
Posted Jan 08, 2026 - 23:16 UTC

Update

What happened: Between January 6, 8:01 PM UTC and January 7, 2:52 PM UTC, we experienced an issue where $set, $set_once, and $unset operations on person properties were not being applied correctly. This affected both US Cloud and EU Cloud.

What was the impact: Person property updates sent during this ~19 hour window were not applied to person profiles. If your implementation sets properties like email, name, or other custom person properties, those updates may be missing for users whose properties were set during the affected period. This was caused by a bug in our person property update logic that has since been fixed—all new events are now processing correctly.

What we're doing about it: Our engineering team is actively working on a remediation to recover and reapply the affected person property updates. We have the underlying data needed to restore these properties and are building a process to do so safely. We'll follow up once remediation is complete.

You can also re-send any person properties that were updated in that time period, those updates will be applied immediately.

A note on data exports: If you're exporting data to a warehouse (Snowflake, BigQuery, etc.): timeseries event data remains accurate. However, if you're exporting point-in-time snapshots of the Persons table, those records won't reflect the correct state until our remediation is complete. Running a backfill now won't resolve this—please wait until we confirm the fix is in place.
Next steps: We're publishing a detailed post-mortem with the full timeline and technical details. We'll share that with you once it's available, along with confirmation when the data remediation is complete.
Posted Jan 07, 2026 - 20:54 UTC

Identified

(this is a follow up to the earlier incident)

We reverted the changed that caused property updates to not be applied to person profiles. All person property updates are now processed correctly.

**Update**: We are currently working on backfilling person properties that were affected before. If you are seeing inconsistent results, you can either wait for this backfilling to complete, or re-send any person properties that were sent in between Jan 6th 20:00 UTC and Jan 7th 14:52 UTC
Posted Jan 07, 2026 - 20:51 UTC