Elevated API Errors

Incident Report for PostHog

Resolved

Partial event loss during the incident window in EU and US zones, due to exhausted retries during windows of 503s in event capture. Service is recovered now.
Posted Aug 01, 2025 - 01:34 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 01, 2025 - 01:06 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 01, 2025 - 00:10 UTC

Monitoring

We experienced elevated errors on our event ingestion endpoints, resulting in the loss of some events for customers in both the EU and US regions.

The problem has been resolved and operators are taking action to make sure the issue doesn't recur.
Posted Jul 31, 2025 - 23:28 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion Success) and EU Cloud 🇪🇺 (Event and Data Ingestion Success).