Elevated API Errors

Incident Report for PostHog

Resolved

We've identified the problem as routine automated maintenance that failed in a partially applied state, causing a partial outage in our analytics cluster. System is recovering now and API error rates have returned to normal
Posted Jun 14, 2025 - 21:16 UTC

Investigating

We're experiencing an elevated level of query failure from our analytics database systems. We are currently looking into the issue. No data has been lost, but queries, insights, replays, and other product features may be down or intermittently failing.
Posted Jun 14, 2025 - 20:41 UTC
This incident affected: US Cloud 🇺🇸 (App, API /query Endpoint).