US: Web portal slow

Incident Report for PostHog

Resolved

Systems are stable, apologies for the inconveniences!
Posted Aug 07, 2025 - 10:03 UTC

Update

We identified unusual amounts of data ingested to our databases and mitigated this.

Performance metrics indicate instant relief after mitigating this. We should be in the clear and are monitoring this.
Posted Aug 07, 2025 - 09:50 UTC

Investigating

We've spotted that something has gone wrong and seeing intermitting upstream errors in the web portal and API.

We're currently investigating the issue, and will provide an update soon.
Posted Aug 07, 2025 - 09:39 UTC
This incident affected: US Cloud 🇺🇸 (App).