Person deletes failing in EU
Incident Report for PostHog
Resolved
Two missing indexes were created, which resolved the query time out that was the root cause of the deletion failure. Delete API requests should now be functioning as normal.
Posted Jan 15, 2025 - 08:44 UTC
Identified
We're seeing that person deletes via the API are returning an elevated number of 504's/time outs in the EU region. This appears to be due to degraded query performance in our database, along the path required to delete person profiles. We're working to resolve this now.
Posted Jan 10, 2025 - 16:26 UTC
This incident affected: EU Cloud 🇪🇺 (App).