Some dashboards with SQL insights may fail to load
Incident Report for PostHog
Resolved
We think the impact from the issue is over.
Posted Apr 24, 2024 - 22:43 UTC
Monitoring
Dashboards and saved insights should be loading as expected now, but we're continuing to monitor.
Posted Apr 24, 2024 - 19:30 UTC
Identified
We've rolled out a change which makes caching more consistent for SQL and event explorer insights – but it unintentionally also made PostHog calculate those insights every time one is loaded, including within a dashboard. As a result, some existing dashboards show a "Not found" message.

Those dashboards still exist and we're about to deploy a fix for the root cause: https://github.com/PostHog/posthog/pull/21823
Posted Apr 24, 2024 - 17:36 UTC
This incident affected: US Cloud 🇺🇸 (App) and EU Cloud 🇪🇺 (App).