Session replay buffering

Incident Report for PostHog

Resolved

The endless buffering issue affecting some longer session replays appears to be resolved. Longer recordings may still take a bit more time to buffer, but they should now load as expected.
Posted Oct 30, 2025 - 14:50 UTC

Monitoring

A fix for the endless buffering issue on longer session replays has been deployed, and we’re monitoring the results.
Posted Oct 30, 2025 - 13:57 UTC

Investigating

We’re aware that a number of users are experiencing much longer buffering times when viewing extended session replay recordings.
Posted Oct 30, 2025 - 11:27 UTC
This incident affected: PostHog.com.