Posthog EU app not loading

Incident Report for PostHog

Resolved

The problem was solved.
Posted Sep 09, 2025 - 17:47 UTC

Investigating

We're experiencing issues on the EU web app and we are currently investigating.
Posted Sep 09, 2025 - 17:32 UTC