Processing Delays for Realtime Destinations

Incident Report for PostHog

Resolved

We have a deployed a fix to the pipeline that was not handling errors correctly and delivery is back to normal.
Posted Jul 21, 2025 - 18:01 UTC

Investigating

Our data processing infrastructure is running behind which is causing delays in realtime destination delivery. No data has been lost and the system should be caught up shortly.
Posted Jul 21, 2025 - 17:26 UTC
This incident affected: US Cloud 🇺🇸 (Destinations).