Data pipeline delivery delays in US Cloud

Incident Report for PostHog

Resolved

We've identified the bottleneck and fixed it with improved alerting to avoid the issue in the future.
Posted Apr 10, 2025 - 23:59 UTC

Investigating

Pipeline destinations are currently experiencing delays in US Cloud - this means deliveries may be sent significantly later than the event that triggers it. No data has been lost and the deliveries will happen as we catch up on processing
Posted Apr 10, 2025 - 15:41 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion).