Verification emails delivery delays

Incident Report for PostHog

Resolved

The email delivery delays have been resolved.
Posted Dec 08, 2025 - 22:30 UTC

Update

Customer.io incident resolved, we re-enabled verification emails
Posted Dec 08, 2025 - 21:40 UTC

Monitoring

We're seeing delays with verification and password reset emails due to an ongoing incident with Customer.io:
https://status.customerio.com/incidents/x5hwkcw0ddds
To unblock logins, we've temporarily disabled verification emails until the issue is resolved.
Posted Dec 08, 2025 - 20:14 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Dec 08, 2025 - 19:51 UTC

Investigating

We're seeing an unusual spike in tickets about login verification emails and password reset emails not being received. We're currently investigating.
Posted Dec 08, 2025 - 19:44 UTC
This incident affected: US Cloud 🇺🇸 (App) and EU Cloud 🇪🇺 (App).