We have been able to increase the parallelization when inserting events to our ClickHouse cluster tables and lag have been recovered.
We'll keep monitoring it, and if we see an increase again we will update the status page.
Posted Aug 24, 2024 - 21:00 UTC
Monitoring
We are monitoring the progress of catching up on the parts that have fallen behind. We will update as soon as we have finished catching up. Currently all events should be reported within 12 hours of them being received. This will lower as we catch up on our backlog here.
Posted Aug 23, 2024 - 06:11 UTC
Investigating
We've spotted that our distributed tables created for the ingestion of events into ClickHouse are building a big backlog and are taking more time than expected to flush events so they are queryable from the PostHog application.
We are currently investigating the issue to reduce the lag as soon as possible.
Posted Aug 22, 2024 - 16:04 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion).