Session Replay - Recordings Delayed

Incident Report for PostHog

Resolved

Our ingestion service has caught up and all recordings are now available in the app
Posted Nov 07, 2025 - 11:00 UTC

Identified

Our team has identified the root cause of the session recording lag. No data has been lost and we are working on a fix so that recent recordings should be available shortly
Posted Nov 07, 2025 - 10:44 UTC

Investigating

Our team are investigating why some teams are not seeing session recordings for the past 15 hours.
Posted Nov 07, 2025 - 10:16 UTC
This incident affected: US Cloud 🇺🇸 (Session Replay Ingestion) and EU Cloud 🇪🇺 (Session Replay Ingestion).