Elevated API Errors Evaluating Feature Flags

Incident Report for PostHog

Resolved

After adding more database capacities feature flag evaluation has recovered to normal values.

We close this incident now, but keep monitoring.
We're working on a long term fix.

Apologies for the inconvenience.
Posted Apr 15, 2025 - 07:15 UTC

Monitoring

We saw a surge in feature flag evaluations and increased backend and database capacity. Seeing first signs of recovery.
Posted Apr 15, 2025 - 06:54 UTC

Investigating

US: We're experiencing an elevated level of feature flags API errors and are currently investigating.
Posted Apr 15, 2025 - 06:18 UTC
This incident affected: US Cloud 🇺🇸 (Feature Flags and Experiments).