Query performance degraded in US

Incident Report for PostHog

Resolved

We were able to identify the workload causing the issue and mitigated it.

Queries should now respond as expected.
Posted Dec 16, 2025 - 14:11 UTC

Investigating

We have spotted a huge load spike in our ClickHouse cluster and we are investigating the root cause.

Query performance is degraded and the app may not respond as expected.
Posted Dec 16, 2025 - 12:50 UTC
This incident affected: US Cloud 🇺🇸 (App, API /query Endpoint).