API Query endpoint intermittently 500'ing

Incident Report for PostHog

Resolved

This incident was resolved over the weekend.
Posted Apr 22, 2025 - 08:50 UTC

Monitoring

We've shed load and haven't seen errors re-occur yet. We'll continue monitoring this over the weekend.
Posted Apr 17, 2025 - 22:59 UTC

Investigating

The API query endpoint is throwing intermittent 500 errors due to capacity limits on our end. We are working to fix this on our end and make the errors more clear.
If known valid queries are failing with 500s, we recommend retrying queries with exponential backoff.
Posted Apr 17, 2025 - 19:56 UTC
This incident affected: US Cloud 🇺🇸 (App).