High volume of requests in EU

Incident Report for PostHog

Resolved

The fix worked as expected and systems are now back to normal.
Posted Aug 01, 2025 - 13:16 UTC

Monitoring

We found a bug in the codebase that led to the endpoint being requested in a loop and was causing the overload.

We have pushed a fix and now monitoring it. Systems look to be back to normal for now.
Posted Aug 01, 2025 - 12:56 UTC

Update

We have found the endpoint that was causing the issue and we are blocking requests made to it. The load in our system has decreased a lot and the performance is improving.

We are working on a fix so we can unblock the endpoint.
Posted Aug 01, 2025 - 12:31 UTC

Investigating

We are receiving a higher volume of requests than usual and our system may not be able to respond with the expected performance.

We are investigating the root cause.
Posted Aug 01, 2025 - 11:16 UTC
This incident affected: EU Cloud 🇪🇺 (App, API /query Endpoint).