US degraded performance

Incident Report for PostHog

Resolved

We rolled out a change that increased load causing queries to be slower. We rolled back that change so performance should be back up.
Posted May 07, 2025 - 10:13 UTC

Investigating

We have spotted that our data infrastructure is under heavy load and it's impacting the time the app takes to load insights or leading to errors when loading them.

We are investigating what could be the root cause.
Posted May 07, 2025 - 09:07 UTC
This incident affected: US Cloud 🇺🇸 (App).