US: feature flags API with elevated error rate, delayed realtime destinations

Incident Report for PostHog

Resolved

We are fully caught up and operational without realtime destination delays.
Posted Dec 15, 2025 - 14:15 UTC

Monitoring

We're monitoring while the rollback is progressing - feature flags returned to normal values and destinations are still catching up.
Posted Dec 15, 2025 - 13:49 UTC

Update

The rollback is progressing and performance and error rates have recovered.

Due to this faulty config change, we accumulated 2-3 minutes of delayed realtime destinations that are currently catching up.
Posted Dec 15, 2025 - 13:46 UTC

Identified

We identified a faulty change that we are currently rolling back. We're monitoring and seeing signs of recovery.
Posted Dec 15, 2025 - 13:42 UTC

Investigating

We've spotted that something has gone wrong and observing an elevated error rate with feature flags. We're currently investigating the issue, and will provide an update soon.
Posted Dec 15, 2025 - 13:33 UTC
This incident affected: US Cloud 🇺🇸 (Feature Flags and Experiments, Destinations).