US Cloud Web App Down

Incident Report for PostHog

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 16:50 UTC

Update

We have identified the cause and should have a fix rolled out within the next few minutes
Posted Sep 18, 2025 - 16:46 UTC

Identified

A deployment issue has caused the US Cloud web app to fail to load. Data ingestion and APIs are unaffected.
Posted Sep 18, 2025 - 16:46 UTC
This incident affected: US Cloud 🇺🇸 (App).