US: Increased person processing load is causing locks on the replica DB

Incident Report for PostHog

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 09:50 UTC

Monitoring

We scaled up the processing to ease out the spike. We are monitoring the situation.
Posted Mar 21, 2025 - 23:56 UTC

Identified

Performance on the posthog read replica database is a bit degraded due to a high load of person ingestion processing. This is occasionally affecting flag evaluation since the feature flag service depends on the read replica database
Posted Mar 21, 2025 - 21:05 UTC
This incident affected: US Cloud 🇺🇸 (Feature Flags and Experiments).