Data Processing Delays - Reporting Tools Affected

Incident Report for PostHog

Resolved

Event processing is back to healthy rates and we have worked through the backlog of events. The issue is resolved
Posted Jun 19, 2025 - 20:56 UTC

Monitoring

The root cause has been identified and our event processing rate is healthy again. There will be some residual lag as we churn through the backlog of events but that should be resolved within the hour
Posted Jun 19, 2025 - 20:06 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Jun 19, 2025 - 17:39 UTC