CDP Realtime Destinations Delayed

Incident Report for PostHog

Resolved

We think the impact from the issue is over.
Posted Oct 08, 2025 - 12:07 UTC

Update

After monitoring the behaviour for a while we don't see the issue coming up again. We are back to normal.
Posted Oct 08, 2025 - 07:10 UTC

Monitoring

We deployed a fix that should prevent this problem from happening in the future.
Posted Oct 07, 2025 - 14:27 UTC

Update

We saw pods being stuck and redeployed. This fixed the issue temporarily. We are still investigating the root cause.
Posted Oct 07, 2025 - 08:01 UTC

Investigating

Our data processing infrastructure is running behind which is causing delays in some types of CDP destinations. No data has been lost and the system should be caught up shortly.
Posted Oct 07, 2025 - 07:05 UTC
This incident affected: US Cloud 🇺🇸 (Destinations).