Data Processing Delays - Destinations affected

Incident Report for PostHog

Resolved

We've deployed the fix and processing is back to normal.
Posted Jul 15, 2025 - 07:42 UTC

Monitoring

We have found the issue due to some bad handling of utf8 encoding in some messages.
The fix has been deployed and processing is catching up.
Posted Jul 15, 2025 - 06:35 UTC

Identified

Our Destination delivery system is delayed in the EU region. We are investigating the situation
Posted Jul 15, 2025 - 05:50 UTC
This incident affected: EU Cloud 🇪🇺 (Destinations).