Elevated API and web errors

Incident Report for PostHog

Resolved

We identified a faulty compute node as root cause of this.

After moving all workloads off this node and removing the node from our infrastructure, error rates are consistently within our expected values.

Thank you for your patience.
Posted Dec 11, 2025 - 14:02 UTC

Monitoring

We found a few faulty webservers being responsible for this and removed from load balancing.

Seeing signs of recovery and monitoring.
Posted Dec 11, 2025 - 13:46 UTC

Investigating

We're experiencing an elevated level of API errors in the web portal and parts of the API and are currently looking into the issue.
Posted Dec 11, 2025 - 13:38 UTC
This incident affected: EU Cloud 🇪🇺 (App).