Queries are slow to run

Incident Report for PostHog

Resolved

All queries are running as expected
Posted Jun 06, 2025 - 22:34 UTC

Monitoring

We have found and remediated the issue. Query times have already improved. We are just waiting on our infrastructure to fully recover before closing this issue out.
Posted Jun 06, 2025 - 15:21 UTC

Investigating

We've been alerted to an increase in query times. We're currently investigating the issue, and will provide an update once we identify the root cause.
Posted Jun 06, 2025 - 13:44 UTC
This incident affected: US Cloud 🇺🇸 (App, API /query Endpoint).