Cohort recalculations taking longer than expected

Incident Report for PostHog

Resolved

We've caught up on backlogs, deployed a fix, and everything should be back to normal. Thanks for your patience!
Posted Jun 10, 2025 - 16:22 UTC

Monitoring

We've spotted a small number of cohorts are stuck in a recalculating state, and a larger number are taking longer than 24 hours to automatically recalculate as they should. We've identified the issue and have deployed a fix.
Posted Jun 10, 2025 - 15:41 UTC
This incident affected: US Cloud 🇺🇸 (App) and EU Cloud 🇪🇺 (App).