US: Delayed data processing due to patching event

Incident Report for PostHog

Resolved

Patching is done and we processed the data.

Thank you for your patience.
Posted Jul 02, 2025 - 14:45 UTC

Monitoring

Due to a security patching event in our event processing infrastructure, data processing is delayed.

We're monitoring and will update once this is over.

No data will be lost during this operation.
Posted Jul 02, 2025 - 12:23 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion Lag).