Intermitting API erorrs - API endpoints & feature flags

Incident Report for PostHog

Resolved

Looking good, resolved!
Posted Apr 28, 2025 - 12:14 UTC

Monitoring

We scaled the infrastructure components and are monitoring this.

First signs indicate recovery. We will come back with an update once this is verified.
Posted Apr 28, 2025 - 10:50 UTC

Identified

We identified intermitting 500s on several API endpoints, incl. feature flags.

Reason seems to be an underprovisioned infrastructure compoenent.

We're working on a fix. Apologies for any inconvenience
Posted Apr 28, 2025 - 09:56 UTC
This incident affected: EU Cloud 🇪🇺 (App, Feature Flags and Experiments) and US Cloud 🇺🇸 (Feature Flags and Experiments).