Increased parts count impacting performance

Incident Report for PostHog

Resolved

Parts are back to normal and the cluster is responding normally again.

We'll keep monitoring it and let you know if we find misbehavior again.
Posted May 17, 2025 - 10:32 UTC

Investigating

We are currently investigating increased parts counts on our datastore and we are investigating why these parts are not being merged as they should. This will cause increased query times.
Posted May 17, 2025 - 06:38 UTC
This incident affected: US Cloud 🇺🇸 (App).