Data Processing Delays - Reporting Tools Affected

Incident Report for PostHog

Resolved

This incident has been resolved.
Posted May 22, 2025 - 19:59 UTC

Monitoring

We identified the issue and the ingestion pipeline is catching up.
Posted May 22, 2025 - 18:58 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost.
Posted May 22, 2025 - 18:20 UTC