Data Processing Delays - Reporting Tools Affected

Incident Report for PostHog

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 02:06 UTC

Monitoring

We're monitoring the ingestion pipeline, as it processes the delayed messages. We're estimating that the system will fully recover within an hour.
Posted Apr 23, 2025 - 00:01 UTC

Update

We are still investigating intermittent latency spikes in the event ingestion pipeline. Events are still being processed with a delay, which should decrease over time.
Posted Apr 22, 2025 - 21:53 UTC

Update

We are still investigating the root cause of the issue. Events are still delayed but the delay is no longer increasing. We hope to have a resolution shortly
Posted Apr 22, 2025 - 15:26 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Apr 22, 2025 - 13:22 UTC
This incident affected: US Cloud 🇺🇸 (Event and Data Ingestion).