Degraded Performance on Database
Incident Report for PostHog
Resolved
Part counts are back to normal and replicas are up to date! Happy Hoggin!
Posted Jan 29, 2021 - 19:18 UTC
Monitoring
The issue with performance was related to a spike in parts for one of our reporting tables dramatically slowing down query times. This table has been replaced with a table with much fewer parts. It will take some time for replication to occur across the cluster.
Posted Jan 29, 2021 - 18:36 UTC
Investigating
We are currently investigating why a table on our OLAP database has significantly increased number of parts causing backups of queries. Data ingestion is not effected but the app and dashboards may be unstable.
Posted Jan 29, 2021 - 17:33 UTC
This incident affected: US Cloud 🇺🇸 (App).